Wednesday, September 12, 2012

Fun with a Dell Latitude D600 running Ubuntu

While I'm not a total technological klutz I do a fair impersonation most of the time. But one thing I love to try and do is keep old gadgets and machines running.

Not long after the Dell Latitude D-600 came out in 2003 Michele gave me one she had received in a rewards scheme. It was a lovely gesture and I appreciated it hugely.

The only trouble was that from Day 1 the machine had problems. People who don't like dogs the way I do might say it was a dog. Running Windows XP, it crashed, overheated, and generally behaved very badly. We re-installed XP, but to no avail. It would do some of the things it was supposed to, albeit slowly, laboriously.

I cherished the machine as a gift, but it was just sad that it never really performed.

When the first Asus eeePC netbook came out I got one -- my first taste of Linux. I liked it a lot and when I got the second and then third gen Asus netbooks (running XP, as they did, but with bigger hard drives) I would partition the drives and drop Linux on as well -- in the form of Ubuntu. A nice, elegant OS running around 700 megabytes. The machines always seemed to cruise when running Ubuntu.

So, I began to wonder what might happen with the Dell if I ran Ubuntu. What happened was that it stopped crashing. This was back in the days of Ubuntu 7 or 8. It ran well. So I decided to just abandon the Windows OS completely and repartitioned the drive to just run Ubuntu. All of a sudden printers synched beautifully and I was looking at a new -- although by then chronologically rather old -- machine.

In recent years I upgraded through Ubtunu 9 (a favourite), 10 and 11.

The other day after getting back to Mexico at the end of summer I fired the machine up and it said there was a new upgrade, did I want to try it. In the past I have usually created a CD ROM or a thumb stick and installed the upgrades by booting from the ROM or stick. This time I decided to try upgrade right off the download on the web. We are talking Mexico City here, on a slow wireless connection. The stuff came down at between 30 and 60 kps, and the whole job took around 5 hours from starting the download to completing the install. In retrospect I wondered if I might have done better using an ethernet connection rather than wireless, but I maybe should have thought about that earlier. In the event the wireless did the job.

It was great, EXCEPT with the upgrade that I had real trouble getting the wireless to work. In fact, it could not pick up a signal from the same wireless modem it had downloaded the upgrade from. Weird, I thought. I ran it on an ethernet connection and it was fine. Not fast, but at least as good as my more recent machines could manage on wireless.

Meanwhile, I was gearing up to come over to the house in Coatepec. In the downstairs office I have been running a 1998 IBM Thinkpad (on XP Service Pack 1 -- I said I liked keeping old stuff alive) as a printing mule. The specs are so primitive it can't even take Service Pack 2. I had reluctantly decided to retire the faithful old thing with dignity, and it would join the ranks of the old Toshibas and e-Machines that still boot up running Win 95 and 98 respectively. And the Dell Latitude was designated to take over. So I brought if over here with me.

I found that it would pick up the wireless signal here -- slightly less congested infrastructure in Coatepec than Mexico City. It picked up the signal on the upstairs base station much better than the downstairs one. Not flash, I'd say at best comparable to how it ran in Mexico City when it was downloading the new OS. Much slower on the other modem downstairs. It would lose the link and reconnect. I could send email messages. So, in Mexico City I couldn't work the wireless at all after the upgrade, and with a slightly better link over here I could at least get something going upstairs.

Just for fun I wondered what would happen if I plugged in the modest TP Link High Gain USB adapter I had got a few months back. I didn't know if it would run on Ubuntu, and most of the info I could find online said it wouldn't work. But most posts referred to Ubuntu 8 through 10. Because of the weird experience of the wireless function deteriorating with the latest upgrade I thought there was nothing to lose by at least having a shot.

I was wanting to work in the bedroom, which is at the far end of the house from the upstairs base station, and the signal was pretty weak. I slotted the adapter in and it showed a green light, so I disconnected the connection I had and went for the strongest one showing - the USB bus adapter.

What happened was beyond belief. All of a sudden this modest ADSL connection was flying as fast as the cable connection we have in New Jersey. I pulled a couple of music albums down off Amazon cloud in no time at all. The high gain adapter is getting a much better result than with the other machines we have tried it on (running Windows 7 -- a laptop and a netbook). I couldn't believe what was happening.

Right now I have this old modest Dell laptop which will turn 10 next year running about as well as I need a machine to run for most of the things I do most of the time. Not bad for free (open source) software. Not only does Ubuntu keep this machine with its old specs on the road. It has got it flying, and even somehow syncs with a wireless USB high gain adapter I haven't seen anyone else report having got to work in Ubuntu.

It makes me wonder about all those poor slow old machines we see in some of the schools we work and teach in, labouring along trying to run XP and Vista. I wouldn't mind betting that a good proportion of them would get up and run if the tech administrators would let some of the students drop some decent open source software onto them. It wouldn't even be a budget item. And you don't need any significant expertise to do it. After all, if I can do it who can't?

Comments: Post a Comment

Links to this post:

Create a Link



<< Home

This page is powered by Blogger. Isn't yours?